Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(48)

Unified Diff: content/browser/renderer_host/delegated_frame_host.h

Issue 2708153005: Rename SurfaceIdAllocator to LocalSurfaceIdAllocator (Closed)
Patch Set: Delete useless include Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: content/browser/renderer_host/delegated_frame_host.h
diff --git a/content/browser/renderer_host/delegated_frame_host.h b/content/browser/renderer_host/delegated_frame_host.h
index 94b12e8b49c4893645a202011824d2b085608e23..6b3b0b1b6c437f528c38500d35327fb033d59001 100644
--- a/content/browser/renderer_host/delegated_frame_host.h
+++ b/content/browser/renderer_host/delegated_frame_host.h
@@ -31,6 +31,7 @@ class TickClock;
}
namespace cc {
+class LocalSurfaceIdAllocator;
class SurfaceFactory;
}
@@ -287,7 +288,7 @@ class CONTENT_EXPORT DelegatedFrameHost
SkColor background_color_;
// State for rendering into a Surface.
- std::unique_ptr<cc::SurfaceIdAllocator> id_allocator_;
+ std::unique_ptr<cc::LocalSurfaceIdAllocator> id_allocator_;
std::unique_ptr<cc::SurfaceFactory> surface_factory_;
gfx::Size current_surface_size_;
float current_scale_factor_;

Powered by Google App Engine
This is Rietveld 408576698