|
|
Created:
3 years, 10 months ago by Łukasz Anforowicz Modified:
3 years, 10 months ago Reviewers:
dgozman CC:
v8-reviews_googlegroups.com, v8-merges_googlegroups.com, Paweł Hajdan Jr. Target Ref:
refs/pending/heads/master Project:
v8 Visibility:
Public. |
DescriptionAdapt String::find method via StringUtil adapter.
This is needed to insulate generated code from blink::protocol namespace
from naming changes that we plan to do in the Great Blink Rename (which
in particular will rename wtf::StringBuilder::find method into Find).
This CL also includes roll of inspector_protocol which starts to
generate code that uses the new StringUtil::find adapter method:
rolling third_party/inspector to 1a7cbe8ba8fa0d622586f549a97c73d9b52efbea
BUG=683447
Review-Url: https://codereview.chromium.org/2675763003
Cr-Commit-Position: refs/heads/master@{#42936}
Committed: https://chromium.googlesource.com/v8/v8/+/de20581ca37011d6ef9490b6c3f25c1a594ab200
Patch Set 1 #Patch Set 2 : Rebasing... #
Total comments: 2
Patch Set 3 : Added |const String& needle| overload for the future use. #Patch Set 4 : Update revision hash for inspector_protocol repo. #
Created: 3 years, 10 months ago
Messages
Total messages: 23 (18 generated)
The CQ bit was checked by lukasza@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
Description was changed from ========== Adapt String::find method via StringUtil adapter. This is needed to insulate generated code from blink::protocol namespace from naming changes that we plan to do in the Great Blink Rename (which in particular will rename wtf::StringBuilder::find method into Find). This CL also includes roll of inspector_protocol which starts to generate code that uses the new StringUtil::find adapter method: rolling third_party/inspector to DO NOT SUBMIT / TODO / FIXME - revision number goes here. BUG=683447 ========== to ========== Adapt String::find method via StringUtil adapter. This is needed to insulate generated code from blink::protocol namespace from naming changes that we plan to do in the Great Blink Rename (which in particular will rename wtf::StringBuilder::find method into Find). This CL also includes roll of inspector_protocol which starts to generate code that uses the new StringUtil::find adapter method: rolling third_party/inspector to DO NOT SUBMIT / TODO / FIXME - revision number goes here. BUG=683447 ==========
The CQ bit was checked by lukasza@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
lukasza@chromium.org changed reviewers: + dgozman@chromium.org
dgozman@, could you PTAL?
lgtm https://codereview.chromium.org/2675763003/diff/20001/src/inspector/string-ut... File src/inspector/string-util.h (right): https://codereview.chromium.org/2675763003/diff/20001/src/inspector/string-ut... src/inspector/string-util.h:35: static size_t find(const String& s, const char* needle) { Let's also have |const String& needle| version.
The CQ bit was checked by lukasza@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
Description was changed from ========== Adapt String::find method via StringUtil adapter. This is needed to insulate generated code from blink::protocol namespace from naming changes that we plan to do in the Great Blink Rename (which in particular will rename wtf::StringBuilder::find method into Find). This CL also includes roll of inspector_protocol which starts to generate code that uses the new StringUtil::find adapter method: rolling third_party/inspector to DO NOT SUBMIT / TODO / FIXME - revision number goes here. BUG=683447 ========== to ========== Adapt String::find method via StringUtil adapter. This is needed to insulate generated code from blink::protocol namespace from naming changes that we plan to do in the Great Blink Rename (which in particular will rename wtf::StringBuilder::find method into Find). This CL also includes roll of inspector_protocol which starts to generate code that uses the new StringUtil::find adapter method: rolling third_party/inspector to 1a7cbe8ba8fa0d622586f549a97c73d9b52efbea BUG=683447 ==========
Thank you for the review. https://codereview.chromium.org/2675763003/diff/20001/src/inspector/string-ut... File src/inspector/string-util.h (right): https://codereview.chromium.org/2675763003/diff/20001/src/inspector/string-ut... src/inspector/string-util.h:35: static size_t find(const String& s, const char* needle) { On 2017/02/03 20:43:39, dgozman (OOO till Feb 13) wrote: > Let's also have |const String& needle| version. Done.
The CQ bit was unchecked by lukasza@chromium.org
The CQ bit was checked by lukasza@chromium.org
The patchset sent to the CQ was uploaded after l-g-t-m from dgozman@chromium.org Link to the patchset: https://codereview.chromium.org/2675763003/#ps60001 (title: "Update revision hash for inspector_protocol repo.")
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
CQ is committing da patch. Bot data: {"patchset_id": 60001, "attempt_start_ts": 1486159244667220, "parent_rev": "6b6ed60155314fc608504b235382909ebedc23d8", "commit_rev": "de20581ca37011d6ef9490b6c3f25c1a594ab200"}
Message was sent while issue was closed.
Description was changed from ========== Adapt String::find method via StringUtil adapter. This is needed to insulate generated code from blink::protocol namespace from naming changes that we plan to do in the Great Blink Rename (which in particular will rename wtf::StringBuilder::find method into Find). This CL also includes roll of inspector_protocol which starts to generate code that uses the new StringUtil::find adapter method: rolling third_party/inspector to 1a7cbe8ba8fa0d622586f549a97c73d9b52efbea BUG=683447 ========== to ========== Adapt String::find method via StringUtil adapter. This is needed to insulate generated code from blink::protocol namespace from naming changes that we plan to do in the Great Blink Rename (which in particular will rename wtf::StringBuilder::find method into Find). This CL also includes roll of inspector_protocol which starts to generate code that uses the new StringUtil::find adapter method: rolling third_party/inspector to 1a7cbe8ba8fa0d622586f549a97c73d9b52efbea BUG=683447 Review-Url: https://codereview.chromium.org/2675763003 Cr-Commit-Position: refs/heads/master@{#42936} Committed: https://chromium.googlesource.com/v8/v8/+/de20581ca37011d6ef9490b6c3f25c1a594... ==========
Message was sent while issue was closed.
Committed patchset #4 (id:60001) as https://chromium.googlesource.com/v8/v8/+/de20581ca37011d6ef9490b6c3f25c1a594... |