Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(617)

Unified Diff: tests/lib/async/intercept_run_async2_test.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Fix 80 chars lines Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: tests/lib/async/intercept_run_async2_test.dart
diff --git a/tests/lib/async/intercept_run_async2_test.dart b/tests/lib/async/intercept_run_async2_test.dart
index c75e458087bb5c464123bf423419116e8488ec99..b1e534c65100ebaca29f7cf536f902e74144ddf3 100644
--- a/tests/lib/async/intercept_run_async2_test.dart
+++ b/tests/lib/async/intercept_run_async2_test.dart
@@ -9,7 +9,7 @@ var events = [];
body() {
events.add("body entry");
- runAsync(() {
+ scheduleMicrotask(() {
events.add("run async body");
});
return 499;
@@ -22,8 +22,8 @@ handler(fun) {
}
main() {
- // Test that runAsync interception works.
- var result = runZonedExperimental(body, onRunAsync: handler);
+ // Test that scheduleMicrotask interception works.
+ var result = runZonedExperimental(body, onScheduleMicrotask: handler);
// No need for a ReceivePort: If the runZonedExperimental disbehaved we
// would have an [events] list that is different from what we expect.
Expect.listEquals(["body entry", "handler", "run async body", "handler done"],

Powered by Google App Engine
This is Rietveld 408576698