Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(81)

Unified Diff: sdk/lib/_internal/pub/lib/src/utils.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Fix 80 chars lines Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/pub/lib/src/utils.dart
diff --git a/sdk/lib/_internal/pub/lib/src/utils.dart b/sdk/lib/_internal/pub/lib/src/utils.dart
index b570d6c580e034b89d755c3ff3ee9aaa7b35e9cf..a2973d9440a630e8ee4063d2a0119b006e2abaf5 100644
--- a/sdk/lib/_internal/pub/lib/src/utils.dart
+++ b/sdk/lib/_internal/pub/lib/src/utils.dart
@@ -602,9 +602,9 @@ Future resetStack(fn()) {
// Using [new Future] adds an asynchronous operation that works around the
// first and second cases described above.
newFuture(fn).then((val) {
- runAsync(() => completer.complete(val));
+ scheduleMicrotask(() => completer.complete(val));
}).catchError((err) {
- runAsync(() => completer.completeError(err));
+ scheduleMicrotask(() => completer.completeError(err));
});
return completer.future;
}

Powered by Google App Engine
This is Rietveld 408576698