Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(157)

Unified Diff: sdk/lib/_internal/pub/lib/src/error_group.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Fix 80 chars lines Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/pub/lib/src/error_group.dart
diff --git a/sdk/lib/_internal/pub/lib/src/error_group.dart b/sdk/lib/_internal/pub/lib/src/error_group.dart
index 33fb62b39aed4dfef759239cbbc8190087dd24d5..26e0e04eb03ffafc78513f254aa433c8a14b113c 100644
--- a/sdk/lib/_internal/pub/lib/src/error_group.dart
+++ b/sdk/lib/_internal/pub/lib/src/error_group.dart
@@ -127,7 +127,7 @@ class ErrorGroup {
_isDone = true;
_done._signalError(error, stackTrace);
- if (!caught && !_done._hasListeners) runAsync((){ throw error; });
+ if (!caught && !_done._hasListeners) scheduleMicrotask((){ throw error; });
}
/// Notifies [this] that one of its member [Future]s is complete.

Powered by Google App Engine
This is Rietveld 408576698