Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(263)

Unified Diff: include/core/SkTypes.h

Issue 257393004: Convert GrCrash->SkFAIL GrDebugCrash->SkDEBUGFAIL (Closed) Base URL: https://skia.googlesource.com/skia.git@master
Patch Set: whitespace change Created 6 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « bench/GrResourceCacheBench.cpp ('k') | include/gpu/GrColor.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: include/core/SkTypes.h
diff --git a/include/core/SkTypes.h b/include/core/SkTypes.h
index 13450cd0117585084f6a8ca7cc7affe4a9261abf..8863b07326558b310119e5485dc2e5ec9ebaa289 100644
--- a/include/core/SkTypes.h
+++ b/include/core/SkTypes.h
@@ -113,6 +113,8 @@ inline void operator delete(void* p) {
#define SkAssertResult(cond) cond
#endif
+#define SkFAIL(message) SK_DEBUGBREAK(false && message)
mtklein 2014/04/30 13:51:37 Isn't this the same as SkDEBUGFAIL?
reed1 2014/04/30 14:01:28 I think SkDEBUGFAIL does nothing in a release buil
bsalomon 2014/04/30 14:01:44 SK_DEBUGBREAK is misnamed. It is really SK_ALWAYSB
+
#ifdef SK_DEVELOPER
#define SkDEVCODE(code) code
#else
« no previous file with comments | « bench/GrResourceCacheBench.cpp ('k') | include/gpu/GrColor.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698