Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(519)

Unified Diff: third_party/WebKit/Source/core/loader/FormSubmission.cpp

Issue 2546063002: Rename FormAssociatedElement to ListedElement (Closed)
Patch Set: Suggested changes made Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/loader/FormSubmission.cpp
diff --git a/third_party/WebKit/Source/core/loader/FormSubmission.cpp b/third_party/WebKit/Source/core/loader/FormSubmission.cpp
index cce84e6e60beda6572b483db74a3107e1594f4db..ddde335f20d17104761bcafe28534055956e9185 100644
--- a/third_party/WebKit/Source/core/loader/FormSubmission.cpp
+++ b/third_party/WebKit/Source/core/loader/FormSubmission.cpp
@@ -227,8 +227,8 @@ FormSubmission* FormSubmission::create(HTMLFormElement* form,
if (submitButton)
submitButton->setActivatedSubmit(true);
bool containsPasswordData = false;
- for (unsigned i = 0; i < form->associatedElements().size(); ++i) {
- FormAssociatedElement* control = form->associatedElements()[i];
+ for (unsigned i = 0; i < form->listedElements().size(); ++i) {
+ ListedElement* control = form->listedElements()[i];
DCHECK(control);
HTMLElement& element = toHTMLElement(*control);
if (!element.isDisabledFormControl())

Powered by Google App Engine
This is Rietveld 408576698