Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(928)

Unified Diff: third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h

Issue 2546063002: Rename FormAssociatedElement to ListedElement (Closed)
Patch Set: Suggested changes made Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
diff --git a/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h b/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
index f6b8beb4d8398f56a69db96dc282671f000859ab..025cca5ace68182badfd508956eea94204919908 100644
--- a/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
+++ b/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
@@ -25,9 +25,9 @@
#ifndef HTMLFormControlsCollection_h
#define HTMLFormControlsCollection_h
-#include "core/html/FormAssociatedElement.h"
#include "core/html/HTMLCollection.h"
#include "core/html/HTMLElement.h"
+#include "core/html/ListedElement.h"
#include "core/html/RadioNodeList.h"
namespace blink {
@@ -61,7 +61,7 @@ class HTMLFormControlsCollection final : public HTMLCollection {
void updateIdNameCache() const override;
void supportedPropertyNames(Vector<String>& names) override;
- const FormAssociatedElement::List& formControlElements() const;
+ const ListedElement::List& listedElements() const;
const HeapVector<Member<HTMLImageElement>>& formImageElements() const;
HTMLElement* virtualItemAfter(Element*) const override;
void invalidateCache(Document* oldDocument = 0) const override;

Powered by Google App Engine
This is Rietveld 408576698