Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(364)

Unified Diff: third_party/WebKit/Source/core/html/HTMLFieldSetElement.cpp

Issue 2546063002: Rename FormAssociatedElement to ListedElement (Closed)
Patch Set: Rename FormAssociatedElement to ListedElement Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/html/HTMLFieldSetElement.cpp
diff --git a/third_party/WebKit/Source/core/html/HTMLFieldSetElement.cpp b/third_party/WebKit/Source/core/html/HTMLFieldSetElement.cpp
index ddb07e8b0e6a531490932f85c179399fb1b99f4b..16e85ee83a2c158fc6fb09e25e5bd4bb953e0826 100644
--- a/third_party/WebKit/Source/core/html/HTMLFieldSetElement.cpp
+++ b/third_party/WebKit/Source/core/html/HTMLFieldSetElement.cpp
@@ -58,7 +58,7 @@ bool HTMLFieldSetElement::matchesValidityPseudoClasses() const {
}
bool HTMLFieldSetElement::isValidElement() {
- const FormAssociatedElement::List& elements = associatedElements();
+ const ListedElement::List& elements = associatedElements();
for (unsigned i = 0; i < elements.size(); ++i) {
if (elements[i]->isFormControlElement()) {
HTMLFormControlElement* control =
@@ -137,8 +137,7 @@ void HTMLFieldSetElement::refreshElementsIfNeeded() const {
}
}
-const FormAssociatedElement::List& HTMLFieldSetElement::associatedElements()
- const {
+const ListedElement::List& HTMLFieldSetElement::associatedElements() const {
refreshElementsIfNeeded();
return m_associatedElements;
}

Powered by Google App Engine
This is Rietveld 408576698