Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(705)

Unified Diff: runtime/lib/double_patch.dart

Issue 23146008: Changed names of parameters of double.parse in patches to match change in external signature. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | sdk/lib/_internal/lib/core_patch.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: runtime/lib/double_patch.dart
diff --git a/runtime/lib/double_patch.dart b/runtime/lib/double_patch.dart
index 8fb5560870fae22fac6b74615227245feb4505a6..9e2abeb4ece9d7ee80a7404bca87f8e635038d55 100644
--- a/runtime/lib/double_patch.dart
+++ b/runtime/lib/double_patch.dart
@@ -39,11 +39,11 @@ patch class double {
}
/* patch */ static double parse(String str,
- [double handleError(String str)]) {
+ [double onError(String str)]) {
var result = _parse(str);
if (result == null) {
- if (handleError == null) throw new FormatException(str);
- return handleError(str);
+ if (onError == null) throw new FormatException(str);
+ return onError(str);
}
return result;
}
« no previous file with comments | « no previous file | sdk/lib/_internal/lib/core_patch.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698