Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(628)

Unified Diff: third_party/WebKit/Source/core/layout/ng/ng_margin_strut.h

Issue 2281763002: [layoutng] Move and rename NGBoxMargins to NGBoxStrut (Closed)
Patch Set: Created 4 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/layout/ng/ng_margin_strut.h
diff --git a/third_party/WebKit/Source/core/layout/ng/ng_margin_strut.h b/third_party/WebKit/Source/core/layout/ng/ng_margin_strut.h
index 0d927309f6ead6b846efbc340bdee60b0dcdcb21..f8d76bf98fa7ca6f0420a9315b7b9d44a8b04f60 100644
--- a/third_party/WebKit/Source/core/layout/ng/ng_margin_strut.h
+++ b/third_party/WebKit/Source/core/layout/ng/ng_margin_strut.h
@@ -10,17 +10,6 @@
namespace blink {
-// Stores the four margins of a box
-struct NGBoxMargins {
- LayoutUnit inline_start;
- LayoutUnit inline_end;
- LayoutUnit block_start;
- LayoutUnit block_end;
-
- LayoutUnit InlineSum() const { return inline_start + inline_end; }
- LayoutUnit BlockSum() const { return block_start + block_end; }
-};
-
// This struct is used for the margin collapsing calculation.
struct NGMarginStrut {
LayoutUnit margin_block_start;
« no previous file with comments | « third_party/WebKit/Source/core/layout/ng/ng_length_utils_test.cc ('k') | third_party/WebKit/Source/core/layout/ng/ng_units.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698