Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(312)

Unified Diff: third_party/WebKit/Source/core/layout/ng/ng_length_utils.h

Issue 2281763002: [layoutng] Move and rename NGBoxMargins to NGBoxStrut (Closed)
Patch Set: Created 4 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/layout/ng/ng_length_utils.h
diff --git a/third_party/WebKit/Source/core/layout/ng/ng_length_utils.h b/third_party/WebKit/Source/core/layout/ng/ng_length_utils.h
index b3a54c9b6f63ca962280d31ea6a4bf0ebf230cdf..2491d172911bb4f018adc7798eee59b740785e21 100644
--- a/third_party/WebKit/Source/core/layout/ng/ng_length_utils.h
+++ b/third_party/WebKit/Source/core/layout/ng/ng_length_utils.h
@@ -12,7 +12,7 @@ class ComputedStyle;
class LayoutUnit;
class Length;
class NGConstraintSpace;
-struct NGBoxMargins;
+struct NGBoxStrut;
enum class LengthResolveType { MinSize, MaxSize, ContentSize, MarginSize };
@@ -44,8 +44,8 @@ CORE_EXPORT LayoutUnit computeBlockSizeForFragment(const NGConstraintSpace&,
const ComputedStyle&,
LayoutUnit contentSize);
-CORE_EXPORT NGBoxMargins computeMargins(const NGConstraintSpace&,
- const ComputedStyle&);
+CORE_EXPORT NGBoxStrut computeMargins(const NGConstraintSpace&,
+ const ComputedStyle&);
} // namespace blink

Powered by Google App Engine
This is Rietveld 408576698