Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(465)

Unified Diff: ui/ozone/platform/wayland/wayland_surface_factory.h

Issue 2147523003: Rename WaylandDisplay to WaylandConnection (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: add argument name Created 4 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: ui/ozone/platform/wayland/wayland_surface_factory.h
diff --git a/ui/ozone/platform/wayland/wayland_surface_factory.h b/ui/ozone/platform/wayland/wayland_surface_factory.h
index 25fa77efdc60faf006cb00fa885c89fa8f9d3347..9a57a83dae8a073c6d8d49183a1f69e817f362ae 100644
--- a/ui/ozone/platform/wayland/wayland_surface_factory.h
+++ b/ui/ozone/platform/wayland/wayland_surface_factory.h
@@ -9,11 +9,11 @@
namespace ui {
-class WaylandDisplay;
+class WaylandConnection;
class WaylandSurfaceFactory : public SurfaceFactoryOzone {
public:
- explicit WaylandSurfaceFactory(WaylandDisplay* display);
+ explicit WaylandSurfaceFactory(WaylandConnection* connection);
~WaylandSurfaceFactory() override;
intptr_t GetNativeDisplay() override;
@@ -35,7 +35,7 @@ class WaylandSurfaceFactory : public SurfaceFactoryOzone {
const gfx::NativePixmapHandle& handle) override;
private:
- WaylandDisplay* display_;
+ WaylandConnection* connection_;
DISALLOW_COPY_AND_ASSIGN(WaylandSurfaceFactory);
};
« no previous file with comments | « ui/ozone/platform/wayland/wayland_pointer_unittest.cc ('k') | ui/ozone/platform/wayland/wayland_surface_factory.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698