Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1281)

Unified Diff: Source/devtools/protocol.json

Issue 21163003: DevTools: Implement undo, redo operations for the DOMStorage views. (Closed) Base URL: https://chromium.googlesource.com/chromium/blink.git@master
Patch Set: Created 7 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « Source/devtools/front_end/ResourcesPanel.js ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: Source/devtools/protocol.json
diff --git a/Source/devtools/protocol.json b/Source/devtools/protocol.json
index 99472a5df7047a0474d05d6be50e7f59cafb80b3..a7bcafdf65644a724ed7a3e53102178143a7556a 100644
--- a/Source/devtools/protocol.json
+++ b/Source/devtools/protocol.json
@@ -1438,6 +1438,16 @@
"description": "Disables storage tracking, prevents storage events from being sent to the client."
},
{
+ "name": "getDOMStorageItemValue",
pfeldman 2013/08/05 15:34:07 I'd rename it to getValue. Otherwise lgtm.
+ "parameters": [
+ { "name": "storageId", "$ref": "StorageId" },
+ { "name": "key", "type": "string" }
+ ],
+ "returns": [
+ { "name": "value", "type": "string", "optional": true }
+ ]
+ },
+ {
"name": "getDOMStorageItems",
"parameters": [
{ "name": "storageId", "$ref": "StorageId" }
« no previous file with comments | « Source/devtools/front_end/ResourcesPanel.js ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698