Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(428)

Side by Side Diff: Source/devtools/protocol.json

Issue 21163003: DevTools: Implement undo, redo operations for the DOMStorage views. (Closed) Base URL: https://chromium.googlesource.com/chromium/blink.git@master
Patch Set: Created 7 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
« no previous file with comments | « Source/devtools/front_end/ResourcesPanel.js ('k') | no next file » | no next file with comments »
Toggle Intra-line Diffs ('i') | Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
OLDNEW
1 { 1 {
2 "version": { "major": "1", "minor": "0" }, 2 "version": { "major": "1", "minor": "0" },
3 "domains": [{ 3 "domains": [{
4 "domain": "Inspector", 4 "domain": "Inspector",
5 "hidden": true, 5 "hidden": true,
6 "types": [], 6 "types": [],
7 "commands": [ 7 "commands": [
8 { 8 {
9 "name": "enable", 9 "name": "enable",
10 "description": "Enables inspector domain notifications." 10 "description": "Enables inspector domain notifications."
(...skipping 1420 matching lines...) Expand 10 before | Expand all | Expand 10 after
1431 "commands": [ 1431 "commands": [
1432 { 1432 {
1433 "name": "enable", 1433 "name": "enable",
1434 "description": "Enables storage tracking, storage events will no w be delivered to the client." 1434 "description": "Enables storage tracking, storage events will no w be delivered to the client."
1435 }, 1435 },
1436 { 1436 {
1437 "name": "disable", 1437 "name": "disable",
1438 "description": "Disables storage tracking, prevents storage even ts from being sent to the client." 1438 "description": "Disables storage tracking, prevents storage even ts from being sent to the client."
1439 }, 1439 },
1440 { 1440 {
1441 "name": "getDOMStorageItemValue",
pfeldman 2013/08/05 15:34:07 I'd rename it to getValue. Otherwise lgtm.
1442 "parameters": [
1443 { "name": "storageId", "$ref": "StorageId" },
1444 { "name": "key", "type": "string" }
1445 ],
1446 "returns": [
1447 { "name": "value", "type": "string", "optional": true }
1448 ]
1449 },
1450 {
1441 "name": "getDOMStorageItems", 1451 "name": "getDOMStorageItems",
1442 "parameters": [ 1452 "parameters": [
1443 { "name": "storageId", "$ref": "StorageId" } 1453 { "name": "storageId", "$ref": "StorageId" }
1444 ], 1454 ],
1445 "returns": [ 1455 "returns": [
1446 { "name": "entries", "type": "array", "items": { "$ref": "It em" } } 1456 { "name": "entries", "type": "array", "items": { "$ref": "It em" } }
1447 ] 1457 ]
1448 }, 1458 },
1449 { 1459 {
1450 "name": "setDOMStorageItem", 1460 "name": "setDOMStorageItem",
(...skipping 2398 matching lines...) Expand 10 before | Expand all | Expand 10 after
3849 "parameters": [ 3859 "parameters": [
3850 { "name": "value", "type": "array", "items": { "type": "obje ct" } } 3860 { "name": "value", "type": "array", "items": { "type": "obje ct" } }
3851 ] 3861 ]
3852 }, 3862 },
3853 { 3863 {
3854 "name": "tracingComplete" 3864 "name": "tracingComplete"
3855 } 3865 }
3856 ] 3866 ]
3857 }] 3867 }]
3858 } 3868 }
OLDNEW
« no previous file with comments | « Source/devtools/front_end/ResourcesPanel.js ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698