Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(737)

Unified Diff: third_party/WebKit/Source/modules/payments/PaymentAddress.h

Issue 2020913002: PaymentRequest: Rename ShippingAddress to PaymentAddress. (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Created 4 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/payments/PaymentAddress.h
diff --git a/third_party/WebKit/Source/modules/payments/ShippingAddress.h b/third_party/WebKit/Source/modules/payments/PaymentAddress.h
similarity index 81%
rename from third_party/WebKit/Source/modules/payments/ShippingAddress.h
rename to third_party/WebKit/Source/modules/payments/PaymentAddress.h
index f4d02f0adfaac713ab190b0635c79b6a809b1eef..3c7a2dcdac01323739d3f7e4fc0f3da3f4ab8f77 100644
--- a/third_party/WebKit/Source/modules/payments/ShippingAddress.h
+++ b/third_party/WebKit/Source/modules/payments/PaymentAddress.h
@@ -2,8 +2,8 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-#ifndef ShippingAddress_h
-#define ShippingAddress_h
+#ifndef PaymentAddress_h
+#define PaymentAddress_h
#include "bindings/core/v8/ScriptWrappable.h"
#include "modules/ModulesExport.h"
@@ -15,13 +15,13 @@
namespace blink {
-class MODULES_EXPORT ShippingAddress final : public GarbageCollectedFinalized<ShippingAddress>, public ScriptWrappable {
+class MODULES_EXPORT PaymentAddress final : public GarbageCollectedFinalized<PaymentAddress>, public ScriptWrappable {
DEFINE_WRAPPERTYPEINFO();
- WTF_MAKE_NONCOPYABLE(ShippingAddress);
+ WTF_MAKE_NONCOPYABLE(PaymentAddress);
public:
- explicit ShippingAddress(mojom::blink::ShippingAddressPtr);
- virtual ~ShippingAddress();
+ explicit PaymentAddress(mojom::blink::PaymentAddressPtr);
+ virtual ~PaymentAddress();
const String& regionCode() const { return m_regionCode; }
const Vector<String>& addressLine() const { return m_addressLine; }
@@ -51,4 +51,4 @@ private:
} // namespace blink
-#endif // ShippingAddress_h
+#endif // PaymentAddress_h
« no previous file with comments | « third_party/WebKit/Source/modules/modules.gypi ('k') | third_party/WebKit/Source/modules/payments/PaymentAddress.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698