[css-grid] Rename GridSpan properties
GridSpan was using old names initialResolvedPosition and
This patch rename them to startLine and endLine.
Some reasons for this refactoring:
* "position" is a vague term not defined in the spec.
* GridSpan is currently storing grid lines. A grid "line" is defined
in the spec: https://drafts.csswg.org/css-grid/#grid-line-concept
* The spec uses the concepts "start" and "end" lines too.
No new tests, no change of behavior.