Chromium Code Reviews
Help | Chromium Project | Gerrit Changes | Sign in
(5)

Issue 1648903002: [css-grid] Rename GridResolvedPosition to GridPositionsResolver (Closed)

Created:
3 years ago by Manuel Rego
Modified:
3 years ago
Reviewers:
svillar, Timothy Loh, rune
CC:
chromium-reviews, jfernandez, szager+layoutwatch_chromium.org, blink-reviews-style_chromium.org, zoltan1, svillar, blink-reviews-layout_chromium.org, pdr+renderingwatchlist_chromium.org, eae+blinkwatch, leviw+renderwatch, Manuel Rego, jchaffraix+rendering, blink-reviews
Base URL:
https://chromium.googlesource.com/chromium/src.git@master
Target Ref:
refs/pending/heads/master
Project:
chromium
Visibility:
Public.

Description

[css-grid] Rename GridResolvedPosition to GridPositionsResolver GridResolvedPosition is not storing a position (track or line) anymore. Currently it's just a utility class to resolve grid positions from style. Renamed the class to avoid confusions. No new tests, no change of behavior. BUG=444011 Committed: https://crrev.com/c2c5d58f6f5001c4883c5f98e1c88a6f98d87bba Cr-Commit-Position: refs/heads/master@{#372340}

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+38 lines, -389 lines) Patch
M third_party/WebKit/Source/core/core.gypi View 1 chunk +2 lines, -2 lines 0 comments Download
M third_party/WebKit/Source/core/layout/LayoutGrid.h View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/core/layout/LayoutGrid.cpp View 11 chunks +16 lines, -16 lines 0 comments Download
M third_party/WebKit/Source/core/style/GridCoordinate.h View 1 chunk +1 line, -1 line 0 comments Download
A + third_party/WebKit/Source/core/style/GridPositionsResolver.h View 3 chunks +4 lines, -5 lines 0 comments Download
A + third_party/WebKit/Source/core/style/GridPositionsResolver.cpp View 8 chunks +14 lines, -14 lines 0 comments Download
D third_party/WebKit/Source/core/style/GridResolvedPosition.h View 1 chunk +0 lines, -50 lines 0 comments Download
D third_party/WebKit/Source/core/style/GridResolvedPosition.cpp View 1 chunk +0 lines, -300 lines 0 comments Download

Messages

Total messages: 10 (5 generated)
Manuel Rego
Simple refactoring that was marked as TODO for a while.
3 years ago (2016-01-29 12:07:28 UTC) #2
rune
lgtm In the description: "an utility class" -> "a utility class".
3 years ago (2016-01-29 12:14:59 UTC) #3
commit-bot: I haz the power
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/patch-status/1648903002/1 View timeline at https://chromium-cq-status.appspot.com/patch-timeline/1648903002/1
3 years ago (2016-01-29 12:25:40 UTC) #6
commit-bot: I haz the power
Committed patchset #1 (id:1)
3 years ago (2016-01-29 14:07:05 UTC) #8
commit-bot: I haz the power
3 years ago (2016-01-29 14:08:04 UTC) #10
Message was sent while issue was closed.
Patchset 1 (id:??) landed as
https://crrev.com/c2c5d58f6f5001c4883c5f98e1c88a6f98d87bba
Cr-Commit-Position: refs/heads/master@{#372340}

Powered by Google App Engine
This is Rietveld 408576698