[css-grid] Rename GridCoordinate to GridArea
As the comment in GridCoordinate says,
it actually represents a grid area as it stores
the initial and final positions in both axis (columns and rows).
Someone can think about a grid coordinate just like a single cell.
However this class was representing an area of several cells.
On top of that the "grid area" concept is defined in the spec:
No new tests, no change of behavior.