Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(301)

Unified Diff: third_party/WebKit/Source/web/WebFrameImplBase.h

Issue 1635873003: Replicating WebFrame::uniqueName across renderers. (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@dump-render-tree3
Patch Set: Removed unnecessary crbug comment. Created 4 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/web/WebFrameImplBase.h
diff --git a/third_party/WebKit/Source/web/WebFrameImplBase.h b/third_party/WebKit/Source/web/WebFrameImplBase.h
index 033ef5b6ff5de3eff32740e2a0c257949f5113ef..d82e0f362a110c39635cfc40dcf9595bc9bfff02 100644
--- a/third_party/WebKit/Source/web/WebFrameImplBase.h
+++ b/third_party/WebKit/Source/web/WebFrameImplBase.h
@@ -31,7 +31,7 @@ class WebFrameImplBase : public RefCountedWillBeGarbageCollectedFinalized<WebFra
public:
virtual ~WebFrameImplBase();
- virtual void initializeCoreFrame(FrameHost*, FrameOwner*, const AtomicString& name, const AtomicString& fallbackName) = 0;
+ virtual void initializeCoreFrame(FrameHost*, FrameOwner*, const AtomicString& name, const AtomicString& fallbackName, const AtomicString& uniqueName) = 0;
// TODO(dcheng): Rename this to coreFrame()? This probably also shouldn't be const...
virtual Frame* frame() const = 0;

Powered by Google App Engine
This is Rietveld 408576698