Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(197)

Unified Diff: sdk/lib/_internal/compiler/implementation/lib/js_helper.dart

Issue 16154017: Rename RuntimeError to CyclicIntializationError, as per spec. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Fix bad merge in js_helper.dart Created 7 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/compiler/implementation/lib/js_helper.dart
diff --git a/sdk/lib/_internal/compiler/implementation/lib/js_helper.dart b/sdk/lib/_internal/compiler/implementation/lib/js_helper.dart
index ab36275286da195ec31e8e5a5ba009c5dc01cc14..554357e35bd526803a1ad0635ac49e1f3fc44cc5 100644
--- a/sdk/lib/_internal/compiler/implementation/lib/js_helper.dart
+++ b/sdk/lib/_internal/compiler/implementation/lib/js_helper.dart
@@ -1444,5 +1444,15 @@ void throwNoSuchMethod(obj, name, arguments, expectedArgumentNames) {
* field that is currently being initialized.
*/
void throwCyclicInit(String staticName) {
- throw new RuntimeError("Cyclic initialization for static $staticName");
+ throw new CyclicInitializationError(
+ "Cyclic initialization for static $staticName");
+}
+
+/**
+ * Error thrown when a runtime error occurs.
+ */
+class RuntimeError implements Error {
+ final message;
+ RuntimeError(this.message);
+ String toString() => "RuntimeError: $message";
}

Powered by Google App Engine
This is Rietveld 408576698