Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(219)

Unified Diff: runtime/tests/vm/dart/isolate_unhandled_exception_test.dart

Issue 16154017: Rename RuntimeError to CyclicIntializationError, as per spec. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Fix bad merge in js_helper.dart Created 7 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: runtime/tests/vm/dart/isolate_unhandled_exception_test.dart
diff --git a/runtime/tests/vm/dart/isolate_unhandled_exception_test.dart b/runtime/tests/vm/dart/isolate_unhandled_exception_test.dart
index f7b0c04e910d3dcec5e15d7d36562f98f6e2fd1b..798221e190ddb47f55537761b05bdef71185bd24 100644
--- a/runtime/tests/vm/dart/isolate_unhandled_exception_test.dart
+++ b/runtime/tests/vm/dart/isolate_unhandled_exception_test.dart
@@ -21,7 +21,7 @@ void entry() {
port.receive((message, replyTo) {
if (message == 'throw exception') {
replyTo.call('throwing exception');
- throw new RuntimeError('ignore this exception');
+ throw new UnsupportedError('ignore this exception');
}
replyTo.call('hello');
port.close();

Powered by Google App Engine
This is Rietveld 408576698