Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(796)

Unified Diff: third_party/WebKit/Source/modules/filesystem/DOMFileSystem.h

Issue 1609313002: Use BlobCallback in toBlob instead of FileCallback (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Rebase master and Renamed mimeType to contentType to match other bits in Blob.h Created 4 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/filesystem/DOMFileSystem.h
diff --git a/third_party/WebKit/Source/modules/filesystem/DOMFileSystem.h b/third_party/WebKit/Source/modules/filesystem/DOMFileSystem.h
index 32910e2a087458cc5e6fa80c429c0815cb91c596..c7bee31a61e96d55931eedc4aed0edf5119e04de 100644
--- a/third_party/WebKit/Source/modules/filesystem/DOMFileSystem.h
+++ b/third_party/WebKit/Source/modules/filesystem/DOMFileSystem.h
@@ -44,7 +44,7 @@
namespace blink {
class DirectoryEntry;
-class FileCallback;
+class BlobCallback;
class FileEntry;
class FileWriterCallback;
@@ -68,7 +68,7 @@ public:
bool hasPendingActivity() const override;
void createWriter(const FileEntry*, FileWriterCallback*, ErrorCallback*);
- void createFile(const FileEntry*, FileCallback*, ErrorCallback*);
+ void createFile(const FileEntry*, BlobCallback*, ErrorCallback*);
// Schedule a callback. This should not cross threads (should be called on the same context thread).
// FIXME: move this to a more generic place.

Powered by Google App Engine
This is Rietveld 408576698