Chromium Code Reviews

Unified Diff: third_party/WebKit/Source/core/frame/LocalFrame.cpp

Issue 1468023002: Rename imageSizeForLayoutObject() to imageSize() (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Make LayoutObject::shouldRespectImageOrientation class static and make use of it Created 5 years, 1 month ago
Use n/p to move between diff chunks; N/P to move between comments.
Jump to:
View side-by-side diff with in-line comments
Index: third_party/WebKit/Source/core/frame/LocalFrame.cpp
diff --git a/third_party/WebKit/Source/core/frame/LocalFrame.cpp b/third_party/WebKit/Source/core/frame/LocalFrame.cpp
index 455246e40e18ec3bbc57456cb5c97b84a929fba1..3c9a822842050860c71c59fee2e55e14d968e9b6 100644
--- a/third_party/WebKit/Source/core/frame/LocalFrame.cpp
+++ b/third_party/WebKit/Source/core/frame/LocalFrame.cpp
@@ -673,7 +673,7 @@ PassOwnPtr<DragImage> LocalFrame::nodeImage(Node& node)
IntRect rect;
- return paintIntoDragImage(*layoutObject, layoutObject->shouldRespectImageOrientation(),
+ return paintIntoDragImage(*layoutObject, LayoutObject::shouldRespectImageOrientation(layoutObject),
GlobalPaintFlattenCompositingLayers, layoutObject->paintingRootRect(rect));
}

Powered by Google App Engine