Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1390)

Unified Diff: chromeos/arc/bridge/common/arc_host_messages.h

Issue 1424503002: arc-bridge: Add IPC message definitions (Closed) Base URL: https://chromium.googlesource.com/a/chromium/src.git@master
Patch Set: Renamed libarcbridge=>bridge/common and addressed feedback Created 5 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: chromeos/arc/bridge/common/arc_host_messages.h
diff --git a/chromeos/arc/bridge/common/arc_host_messages.h b/chromeos/arc/bridge/common/arc_host_messages.h
new file mode 100644
index 0000000000000000000000000000000000000000..c68edf6f87b462cb1eaf2c48d36b66c282fdae4d
--- /dev/null
+++ b/chromeos/arc/bridge/common/arc_host_messages.h
@@ -0,0 +1,15 @@
+// Copyright 2015 The Chromium Authors. All rights reserved.
Shuhei Takahashi 2015/10/26 11:13:40 Why did you decide to have two message definition
Luis Héctor Chávez 2015/10/26 21:03:27 To make it possible to add messages to the code wi
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
+
+// Messages sent from the host to the ARC instance
+// Multiply-included message file, hence no include guard.
+
+#include <stdint.h>
+
+#include "ipc/ipc_message_macros.h"
+
+#define IPC_MESSAGE_START ArcHostMsgStart
+
+IPC_MESSAGE_CONTROL0(ArcHostMsg_Pong)
Shuhei Takahashi 2015/10/26 11:13:40 Typically this should be named as ArcInstanceHostM
Luis Héctor Chávez 2015/10/26 21:03:27 Done
+IPC_MESSAGE_CONTROL0(ArcHostMsg_InstanceReady)

Powered by Google App Engine
This is Rietveld 408576698