Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(553)

Issue 1338373002: be sure to use cached bitmap when we need to upload something to make a texture (Closed)

Created:
5 years, 3 months ago by reed1
Modified:
5 years, 3 months ago
CC:
reviews_skia.org
Base URL:
https://skia.googlesource.com/skia.git@master
Target Ref:
refs/heads/master
Project:
skia
Visibility:
Public.

Description

be sure to use cached bitmap when we need to upload something to make a texture BUG=skia:4334 Committed: https://skia.googlesource.com/skia/+/995b4bddd9a1eef933b0acb3ff03c98e7864a8f9

Patch Set 1 #

Total comments: 1
Unified diffs Side-by-side diffs Delta from patch set Stats (+14 lines, -2 lines) Patch
M src/core/SkBitmapCache.cpp View 2 chunks +10 lines, -1 line 0 comments Download
M src/core/SkImageCacherator.cpp View 2 chunks +4 lines, -1 line 1 comment Download

Messages

Total messages: 13 (5 generated)
reed1
ptal
5 years, 3 months ago (2015-09-14 17:14:32 UTC) #2
commit-bot: I haz the power
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/patch-status/1338373002/1 View timeline at https://chromium-cq-status.appspot.com/patch-timeline/1338373002/1
5 years, 3 months ago (2015-09-14 17:14:46 UTC) #4
commit-bot: I haz the power
Dry run: This issue passed the CQ dry run.
5 years, 3 months ago (2015-09-14 17:20:38 UTC) #6
robertphillips
lgtm
5 years, 3 months ago (2015-09-14 17:26:28 UTC) #7
commit-bot: I haz the power
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/patch-status/1338373002/1 View timeline at https://chromium-cq-status.appspot.com/patch-timeline/1338373002/1
5 years, 3 months ago (2015-09-14 17:27:19 UTC) #9
commit-bot: I haz the power
Committed patchset #1 (id:1) as https://skia.googlesource.com/skia/+/995b4bddd9a1eef933b0acb3ff03c98e7864a8f9
5 years, 3 months ago (2015-09-14 17:28:00 UTC) #10
tomhudson
Noisy sheriff is noisy. https://codereview.chromium.org/1338373002/diff/1/src/core/SkImageCacherator.cpp File src/core/SkImageCacherator.cpp (right): https://codereview.chromium.org/1338373002/diff/1/src/core/SkImageCacherator.cpp#newcode74 src/core/SkImageCacherator.cpp:74: // If you want the ...
5 years, 3 months ago (2015-09-14 17:31:46 UTC) #12
reed1
5 years, 3 months ago (2015-09-14 17:34:42 UTC) #13
Message was sent while issue was closed.
On 2015/09/14 17:31:46, tomhudson wrote:
> Noisy sheriff is noisy.
> 
>
https://codereview.chromium.org/1338373002/diff/1/src/core/SkImageCacherator.cpp
> File src/core/SkImageCacherator.cpp (right):
> 
>
https://codereview.chromium.org/1338373002/diff/1/src/core/SkImageCacherator....
> src/core/SkImageCacherator.cpp:74: // If you want the immutable bitmap with
the
> same ID as our cacherator, call tryLockAsBitmap()
> Is there some way we could change the names of these functions to make the
very
> different semantics clearer? Or are there Skia naming conventions documented
> somewhere that would clue us in to this difference?
> 
> (Could we put a comment about a critical difference like this INTO THE HEADER,
> which is what I'll be reading if I'm trying to figure out how to use the
class?)

Sure, though both of these are private, and only called by the impl itself.

Powered by Google App Engine
This is Rietveld 408576698