Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(486)

Unified Diff: sdk/lib/_internal/compiler/implementation/lib/async_patch.dart

Issue 12793003: Rename Timer.repeating to Timer.periodic. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/compiler/implementation/lib/async_patch.dart
diff --git a/sdk/lib/_internal/compiler/implementation/lib/async_patch.dart b/sdk/lib/_internal/compiler/implementation/lib/async_patch.dart
index 7219f0883a08cd0d2002404a04a8d0f20ba4eddc..9d8b237ef4bea4a38cab51ecaf3c21e29984d3ed 100644
--- a/sdk/lib/_internal/compiler/implementation/lib/async_patch.dart
+++ b/sdk/lib/_internal/compiler/implementation/lib/async_patch.dart
@@ -14,10 +14,10 @@ patch class Timer {
return new TimerImpl(milliseconds, callback);
}
- patch factory Timer.repeating(Duration duration, void callback(Timer timer)) {
+ patch factory Timer.periodic(Duration duration, void callback(Timer timer)) {
int milliseconds = duration.inMilliseconds;
if (milliseconds < 0) milliseconds = 0;
- return new TimerImpl.repeating(milliseconds, callback);
+ return new TimerImpl.periodic(milliseconds, callback);
}
}

Powered by Google App Engine
This is Rietveld 408576698