Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(120)

Unified Diff: samples/swarm/swarm_ui_lib/base/AnimationScheduler.dart

Issue 12793003: Rename Timer.repeating to Timer.periodic. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: samples/swarm/swarm_ui_lib/base/AnimationScheduler.dart
diff --git a/samples/swarm/swarm_ui_lib/base/AnimationScheduler.dart b/samples/swarm/swarm_ui_lib/base/AnimationScheduler.dart
index ce8b254596707cc9743aec78e29bf0b9fda5f7df..2844038aaa9c61563d31ff7edfd25bdfa441fc88 100644
--- a/samples/swarm/swarm_ui_lib/base/AnimationScheduler.dart
+++ b/samples/swarm/swarm_ui_lib/base/AnimationScheduler.dart
@@ -93,7 +93,7 @@ class AnimationScheduler {
// Assert that we never schedule multiple frames at once.
assert(__timer == null);
if (USE_INTERVALS) {
- _timer = new Timer.repeating(const Duration(milliseconds: MS_PER_FRAME),
+ _timer = new Timer.periodic(const Duration(milliseconds: MS_PER_FRAME),
(_) { _step(); });
} else {
if (_webkitAnimationFrameMaybeAvailable) {

Powered by Google App Engine
This is Rietveld 408576698