Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(5588)

Unified Diff: chrome/browser/plugins/chrome_plugin_service_filter.cc

Issue 12209008: Follow-on fixes and naming changes for https://codereview.chromium.org/12086077/ (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: Created 7 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: chrome/browser/plugins/chrome_plugin_service_filter.cc
===================================================================
--- chrome/browser/plugins/chrome_plugin_service_filter.cc (revision 180620)
+++ chrome/browser/plugins/chrome_plugin_service_filter.cc (working copy)
@@ -69,7 +69,7 @@
restricted_plugins_.erase(plugin_path);
}
-bool ChromePluginServiceFilter::IsPluginEnabled(
+bool ChromePluginServiceFilter::IsPluginAvailable(
int render_process_id,
int render_view_id,
const void* context,
@@ -87,10 +87,9 @@
details->overridden_plugins[i].url.is_empty())) {
bool use = details->overridden_plugins[i].plugin.path == plugin->path;
- if (!use)
- return false;
- *plugin = details->overridden_plugins[i].plugin;
- break;
+ if (use)
+ *plugin = details->overridden_plugins[i].plugin;
+ return use;
}
}
}
« no previous file with comments | « chrome/browser/plugins/chrome_plugin_service_filter.h ('k') | chrome/browser/plugins/plugin_info_message_filter.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698