Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(87)

Unified Diff: pkg/serialization/test/serialization_test.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/serialization/test/serialization_test.dart
diff --git a/pkg/serialization/test/serialization_test.dart b/pkg/serialization/test/serialization_test.dart
index 9279ffa384b1b4061eac3681335582d0a3005254..1662f8aac8ba76bd2b803e53068f4d258144ea47 100644
--- a/pkg/serialization/test/serialization_test.dart
+++ b/pkg/serialization/test/serialization_test.dart
@@ -636,7 +636,7 @@ runRoundTripTestFlat(serializerSetUp) {
/** Extract the state from [object] using the rules in [s] and return it. */
states(object, Serialization s) {
var rules = s.rulesFor(object, null);
- return rules.mappedBy((x) => x.extractState(object, doNothing)).toList();
+ return rules.map((x) => x.extractState(object, doNothing)).toList();
}
/** A hard-coded rule for serializing Node instances. */
@@ -648,4 +648,4 @@ class NodeRule extends CustomRule {
node.parent = state[0];
node.children = state[2];
}
-}
+}

Powered by Google App Engine
This is Rietveld 408576698