Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(5760)

Unified Diff: chrome/common/extensions/api/developer_private.idl

Issue 11794034: Adds functionality to pack an extension / app from the app. (Closed) Base URL: http://git.chromium.org/chromium/src.git@bacha_lo
Patch Set: Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: chrome/common/extensions/api/developer_private.idl
diff --git a/chrome/common/extensions/api/developer_private.idl b/chrome/common/extensions/api/developer_private.idl
index f8ee9cd29b0aba44728fabc8aca3138b24db54ab..ec7027989b6f1eb14b21c5641e7a4e55b1e1a1d6 100644
--- a/chrome/common/extensions/api/developer_private.idl
+++ b/chrome/common/extensions/api/developer_private.idl
@@ -68,9 +68,32 @@ namespace developerPrivate {
boolean incognito;
};
+ enum PackStatus {
+ SUCCESS,
+ ERROR,
+ WARNING
+ };
+
+ dictionary PackItemResponse {
+
miket_OOO 2013/01/09 18:52:41 this newline isn't needed (follow style of others
Gaurav 2013/01/12 01:08:26 Done.
+ // The response message of success or error.
+ DOMString message;
+
+ // Unpacked items's path.
+ DOMString item_path;
miket_OOO 2013/01/09 18:52:41 The prevailing style in the IDL is itemPath, pemPa
Gaurav 2013/01/12 01:08:26 I changed the naming from camel case to underscore
+
+ // Permanent key path.
+ DOMString pem_path;
+
+ long override_flags;
+ PackStatus status;
+ };
+
callback BooleanCallback = void (boolean result);
callback ItemsInfoCallback = void (ItemInfo[] result);
callback GetStringsCallback = void (object result);
+ callback PathCallback = void (DOMString path);
+ callback PackCallback = void (PackItemResponse response);
interface Functions {
// Runs auto update for extensions and apps immediately.
@@ -90,25 +113,40 @@ namespace developerPrivate {
static void inspect(InspectOptions options,
BooleanCallback callback);
- // Enable / Disable file access for a given |itemId|
- static void allowFileAccess(DOMString itemId,
- boolean isAllow,
+ // Enable / Disable file access for a given |item_id|
miket_OOO 2013/01/09 18:52:41 Hmmmm. These changes seem to go in the wrong style
Gaurav 2013/01/12 01:08:26 Did them to be consistent with enums. Should I rev
+ static void allowFileAccess(DOMString item_id,
+ boolean is_allow,
miket_OOO 2013/01/09 18:52:41 isAllowed sounds more natural (isEnabled below, to
Gaurav 2013/01/12 01:08:26 Done.
BooleanCallback callback);
- // Reloads a given item with |itemId|
- static void reload(DOMString itemId, BooleanCallback callback);
+ // Reloads a given item with |item_id|
+ static void reload(DOMString item_id, BooleanCallback callback);
- // Uninstalls a given item with |itemId|
- static void uninstall(DOMString itemId, BooleanCallback callback);
+ // Uninstalls a given item with |item_id|
+ static void uninstall(DOMString item_id, BooleanCallback callback);
- // Enable / Disable a given item with id |itemId|
- static void enable(DOMString itemId,
- boolean isEnable,
+ // Enable / Disable a given item with id |item_id|
+ static void enable(DOMString item_id,
+ boolean is_enable,
BooleanCallback callback);
- // Load a user selected unpacked extension
+ // Load a user selected unpacked item
static void loadUnpacked(BooleanCallback callback);
+ // Open Dialog to browse to an entry.
+ // |select_type| : The select type folder or file.
+ // |file_type| : Required file type.
asargent_no_longer_on_chrome 2013/01/09 00:48:05 What are the legal values for this? Does this mean
miket_OOO 2013/01/09 18:52:41 An example would be good if a full enumeration isn
Gaurav 2013/01/12 01:08:26 Done.
Gaurav 2013/01/12 01:08:26 Done.
+ // |callback| : called with selected item's path.
+ static void chooseItem(DOMString select_type,
asargent_no_longer_on_chrome 2013/01/09 00:48:05 Nit: maybe "choosePath" would be a better name for
Gaurav 2013/01/12 01:08:26 Done.
+ DOMString file_type,
+ PathCallback callback);
+
+ // Pack an item with given |item_path| and |private_key_path|
+ // |callback| : called with the success result string.
+ static void packItem(DOMString item_path,
asargent_no_longer_on_chrome 2013/01/09 00:48:05 nit: I assume you use the term 'item' here and els
Gaurav 2013/01/12 01:08:26 Done.
+ DOMString private_key_path,
+ long flags,
+ PackCallback callback);
+
// Gets translated strings.
static void getStrings(GetStringsCallback callback);
};

Powered by Google App Engine
This is Rietveld 408576698