Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(385)

Issue 11299248: Unify object groups iteration in global handles. (Closed)

Created:
8 years ago by Michael Starzinger
Modified:
8 years ago
Reviewers:
ulan
CC:
v8-dev, haraken
Visibility:
Public.

Description

Unify object groups iteration in global handles. This unifies the iteration logic of objects groups iteration in global handles. The scavenger as well as mark-and-compact now rely on the same underlying logic. R=ulan@chromium.org Committed: http://code.google.com/p/v8/source/detail?r=13128

Patch Set 1 #

Total comments: 2

Patch Set 2 : Addressed comments by Ulan Degenbaev. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+69 lines, -105 lines) Patch
M src/global-handles.h View 1 1 chunk +5 lines, -0 lines 0 comments Download
M src/global-handles.cc View 1 1 chunk +45 lines, -0 lines 0 comments Download
M src/heap.h View 1 chunk +0 lines, -2 lines 0 comments Download
M src/heap.cc View 2 chunks +2 lines, -46 lines 0 comments Download
M src/mark-compact.h View 2 chunks +2 lines, -5 lines 0 comments Download
M src/mark-compact.cc View 5 chunks +15 lines, -52 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
Michael Starzinger
8 years ago (2012-11-29 12:20:25 UTC) #1
ulan
LGTM https://chromiumcodereview.appspot.com/11299248/diff/1/src/global-handles.cc File src/global-handles.cc (right): https://chromiumcodereview.appspot.com/11299248/diff/1/src/global-handles.cc#newcode567 src/global-handles.cc:567: if (!f(isolate_->heap(), &object)) { Maybe rename "f" to ...
8 years ago (2012-12-04 09:41:46 UTC) #2
Michael Starzinger
8 years ago (2012-12-04 10:18:14 UTC) #3
Addressed comments. Landing.

https://codereview.chromium.org/11299248/diff/1/src/global-handles.cc
File src/global-handles.cc (right):

https://codereview.chromium.org/11299248/diff/1/src/global-handles.cc#newcode567
src/global-handles.cc:567: if (!f(isolate_->heap(), &object)) {
On 2012/12/04 09:41:46, ulan wrote:
> Maybe rename "f" to something more descriptive like "CanSkipObject"?

Done.

Powered by Google App Engine
This is Rietveld 408576698