Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(283)

Unified Diff: pkg/unittest/mock.dart

Issue 11275054: Modified unittest to use new argument syntax. (Closed) Base URL: http://dart.googlecode.com/svn/branches/bleeding_edge/dart/
Patch Set: Created 8 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/unittest/mock.dart
===================================================================
--- pkg/unittest/mock.dart (revision 14114)
+++ pkg/unittest/mock.dart (working copy)
@@ -432,7 +432,7 @@
_mockFailureHandler =
new _MockFailureHandler(getOrCreateExpectFailureHandler());
}
- expect(logs, matcher, filter, _mockFailureHandler);
+ expect(logs, matcher, reason:filter, failureHandler: _mockFailureHandler);
Jennifer Messerly 2012/10/26 02:57:05 I think this would read better if it was called "f
gram 2012/10/26 22:26:27 It's a class, not a method, so it should be a noun
Jennifer Messerly 2012/10/26 22:50:16 Makes sense. I was assuming it was a callback :)
return this;
}

Powered by Google App Engine
This is Rietveld 408576698