Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(110)

Unified Diff: pkg/unittest/mock.dart

Issue 11230011: Make hasNext a getter instead of a method. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Remove unused variable. Created 8 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « pkg/unittest/core_matchers.dart ('k') | runtime/lib/array.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: pkg/unittest/mock.dart
diff --git a/pkg/unittest/mock.dart b/pkg/unittest/mock.dart
index ded68f35dfff0cef4fa423517ae9ddb1c42a2295..6edb0c8238152bf599b5020101df00330ee30cc7 100644
--- a/pkg/unittest/mock.dart
+++ b/pkg/unittest/mock.dart
@@ -781,7 +781,7 @@ class LogEntryList {
if (includeKeys) {
rtn.logs.add(keyEntry);
}
- if (keyIterator.hasNext()) {
+ if (keyIterator.hasNext) {
keyEntry = keyIterator.next();
} else if (isPreceding) { // We're done.
break;
« no previous file with comments | « pkg/unittest/core_matchers.dart ('k') | runtime/lib/array.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698