Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(363)

Unified Diff: lib/compiler/implementation/util/link_implementation.dart

Issue 11230011: Make hasNext a getter instead of a method. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Remove unused variable. Created 8 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « lib/compiler/implementation/types/concrete_types_inferrer.dart ('k') | lib/core/collection.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: lib/compiler/implementation/util/link_implementation.dart
diff --git a/lib/compiler/implementation/util/link_implementation.dart b/lib/compiler/implementation/util/link_implementation.dart
index a7da8ec5a54458dbc020de0e0711ea80686417b5..20cefe5c100a2784a6d6735ddf8671085d6dab86 100644
--- a/lib/compiler/implementation/util/link_implementation.dart
+++ b/lib/compiler/implementation/util/link_implementation.dart
@@ -5,7 +5,7 @@
class LinkIterator<T> implements Iterator<T> {
Link<T> current;
LinkIterator(Link<T> this.current);
- bool hasNext() => !current.isEmpty();
+ bool get hasNext => !current.isEmpty();
T next() {
T result = current.head;
current = current.tail;
« no previous file with comments | « lib/compiler/implementation/types/concrete_types_inferrer.dart ('k') | lib/core/collection.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698