Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(380)

Unified Diff: lib/compiler/implementation/lib/coreimpl_patch.dart

Issue 11230011: Make hasNext a getter instead of a method. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Remove unused variable. Created 8 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/lib/coreimpl_patch.dart
diff --git a/lib/compiler/implementation/lib/coreimpl_patch.dart b/lib/compiler/implementation/lib/coreimpl_patch.dart
index 9b6306416a565405394216416ce707b75dbb416c..db47433c086ba63e560690c6d32ecf05809ae074 100644
--- a/lib/compiler/implementation/lib/coreimpl_patch.dart
+++ b/lib/compiler/implementation/lib/coreimpl_patch.dart
@@ -236,7 +236,7 @@ class _AllMatchesIterator implements Iterator<Match> {
: _done = false, _re = JSSyntaxRegExp._globalVersionOf(re);
Match next() {
- if (!hasNext()) {
+ if (!hasNext) {
throw const NoMoreElementsException();
}
@@ -246,7 +246,7 @@ class _AllMatchesIterator implements Iterator<Match> {
return next;
}
- bool hasNext() {
+ bool get hasNext {
if (_done) {
return false;
} else if (_next != null) {
« no previous file with comments | « lib/compiler/implementation/js_backend/constant_emitter.dart ('k') | lib/compiler/implementation/lib/interceptors.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698