Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(533)

Unified Diff: lib/compiler/implementation/lib/interceptors.dart

Issue 11230011: Make hasNext a getter instead of a method. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/lib/interceptors.dart
diff --git a/lib/compiler/implementation/lib/interceptors.dart b/lib/compiler/implementation/lib/interceptors.dart
index 8aa6509f96bd68c22e525c77762359d8cec68f0e..aea32d0edc3dd143bbd3bddfc2d60a50b2d4c22f 100644
--- a/lib/compiler/implementation/lib/interceptors.dart
+++ b/lib/compiler/implementation/lib/interceptors.dart
@@ -145,7 +145,7 @@ addAll(receiver, collection) {
// TODO(ahe): Use for-in when it is implemented correctly.
var iterator = collection.iterator();
- while (iterator.hasNext()) {
+ while (iterator.hasNext) {
receiver.add(iterator.next());
}
}

Powered by Google App Engine
This is Rietveld 408576698