Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(229)

Unified Diff: runtime/vm/intrinsifier.h

Issue 11230011: Make hasNext a getter instead of a method. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: runtime/vm/intrinsifier.h
diff --git a/runtime/vm/intrinsifier.h b/runtime/vm/intrinsifier.h
index 7516dbb13c1506d926d3a94eeebe588350d43cc8..0728e4f5e8d261f33520db74e86fc33ae153f8a3 100644
--- a/runtime/vm/intrinsifier.h
+++ b/runtime/vm/intrinsifier.h
@@ -72,8 +72,8 @@ namespace dart {
V(::, sin, Math_sin) \
V(::, cos, Math_cos) \
V(Object, ==, Object_equal) \
+ V(_FixedSizeArrayIterator, get:hasNext, FixedSizeArrayIterator_getHasNext) \
V(_FixedSizeArrayIterator, next, FixedSizeArrayIterator_next) \
- V(_FixedSizeArrayIterator, hasNext, FixedSizeArrayIterator_hasNext) \
V(_StringBase, get:length, String_getLength) \
V(_StringBase, charCodeAt, String_charCodeAt) \
V(_StringBase, hashCode, String_hashCode) \

Powered by Google App Engine
This is Rietveld 408576698