Chromium Code Reviews

Issue 11434118: Add validation infrastructure for "pub lish". (Closed)

Created:
8 years ago by nweiz
Modified:
8 years ago
Reviewers:
Bob Nystrom
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Add validation infrastructure for "pub lish". This also adds a simple validator. BUG=7045 Committed: https://code.google.com/p/dart/source/detail?r=15765

Patch Set 1 #

Patch Set 2 : Refactor + tests #

Patch Set 3 : Fix a chain/transform bug #

Total comments: 19

Patch Set 4 : Code review changes #

Unified diffs Side-by-side diffs Stats (+454 lines, -29 lines)
M utils/pub/command_lish.dart View 3 chunks +22 lines, -1 line 0 comments
M utils/pub/entrypoint.dart View 1 chunk +6 lines, -0 lines 0 comments
M utils/pub/pub.dart View 3 chunks +2 lines, -10 lines 0 comments
M utils/pub/pubspec.dart View 2 chunks +11 lines, -4 lines 0 comments
M utils/pub/system_cache.dart View 2 chunks +13 lines, -0 lines 0 comments
M utils/pub/utils.dart View 2 chunks +5 lines, -2 lines 0 comments
A utils/pub/validator.dart View 1 chunk +71 lines, -0 lines 0 comments
A utils/pub/validator/pubspec_field.dart View 1 chunk +48 lines, -0 lines 0 comments
M utils/tests/pub/pub_lish_test.dart View 1 chunk +59 lines, -0 lines 0 comments
M utils/tests/pub/test_pub.dart View 11 chunks +103 lines, -12 lines 0 comments
A utils/tests/pub/validator_test.dart View 1 chunk +114 lines, -0 lines 0 comments

Messages

Total messages: 5 (0 generated)
nweiz
8 years ago (2012-12-04 23:03:26 UTC) #1
Bob Nystrom
I have some architecture feedback, but overall I really like this approach. I don't know ...
8 years ago (2012-12-05 18:57:40 UTC) #2
nweiz
I think we should wait on figuring out how this applies to installation. https://codereview.chromium.org/11434118/diff/6001/utils/pub/validator.dart File ...
8 years ago (2012-12-05 21:59:59 UTC) #3
Bob Nystrom
LGTM. https://codereview.chromium.org/11434118/diff/6001/utils/pub/validator.dart File utils/pub/validator.dart (right): https://codereview.chromium.org/11434118/diff/6001/utils/pub/validator.dart#newcode5 utils/pub/validator.dart:5: library validator; On 2012/12/05 21:59:59, nweiz wrote: > ...
8 years ago (2012-12-05 22:18:41 UTC) #4
nweiz
8 years ago (2012-12-06 00:06:10 UTC) #5
https://codereview.chromium.org/11434118/diff/6001/utils/pub/validator.dart
File utils/pub/validator.dart (right):

https://codereview.chromium.org/11434118/diff/6001/utils/pub/validator.dart#n...
utils/pub/validator.dart:5: library validator;
On 2012/12/05 22:18:41, Bob Nystrom wrote:
> On 2012/12/05 21:59:59, nweiz wrote:
> > On 2012/12/05 18:57:40, Bob Nystrom wrote:
> > > "validation"?
> > 
> > I think the library name should match the name of the class it defines.
> 
> I actually think it shouldn't since it may make the library name confusing if
it
> later evolves to have more than just that one class. Whenever possible, I
prefer
> inclusive, open-ended sounding library names, though that's not a strong rule.
> (And it's one I violate if I intend the library to be imported with a prefix.)
> 
> I'd prefer "validation" here but if you're really attached to the current
name,
> I guess it works too.

I think open-ended names are good for libraries that are going to contain a wide
variety of things -- io, utils, version_solver I suppose -- but this is intended
to be a simple single-class library, and I think it should be named the same as
all the other single-class libraries in pub.

https://codereview.chromium.org/11434118/diff/6001/utils/pub/validator.dart#n...
utils/pub/validator.dart:28: final errors = <String>[];
On 2012/12/05 22:18:41, Bob Nystrom wrote:
> On 2012/12/05 21:59:59, nweiz wrote:
> > On 2012/12/05 18:57:40, Bob Nystrom wrote:
> > > Instead of exposing these directly to the subclasses, which then lets them
> do
> > > other stuff with the list like remove, clear, etc., how about:
> > > 
> > > 1. Make errors and warnings private.
> > > 2. Add error() and warning() methods to Validator that subclasses can
call.
> > > 3. Make a private _validate() method that takes the collections and then
> calls
> > > the public/protected validate(). This would also spare you from having to
> > > flatten the resulting collections. Like:
> > > 
> > > abstract class Validator {
> > >   List<String> _errors;
> > >   List<String> _warnings;
> > > 
> > >   // Conceptually "protected".
> > >   void error(String message) => _errors.add(message);
> > >   void warning(String message) => _warnings.add(message);
> > > 
> > >   void _validate(List<String> errors, List<String> warnings) {
> > >     _errors = errors;
> > >     _warnings = warnings;
> > >     validate();
> > >   }
> > > 
> > >   void validate();
> > > 
> > >   // Sync for example purposes...
> > >   static void runAll() {
> > >     var errors = [];
> > >     var warnings = [];
> > >     for (var validator in validators) {
> > >       validator._validate(errors, warnings);
> > >     }
> > >   }
> > > }
> > > 
> > > WDYT?
> > 
> > That seems like more machinery than it's worth to prevent us from doing
things
> > we won't actually do.
> > 
> > Conceptually, I do think of "errors" and "warnings" as being streams, which
> your
> > API makes more explicit. I'd like to use the streams v2 API once it's
> available.
> > For now, though, I think sticking with the more straightforward API that
> doesn't
> > require extra parameter declarations is easier.
> 
> This would only require one extra parameter declaration here in this library.
> Subclasses of Validator see the same validate() signature. But it's not a big
> deal either way.

If we do it that way, it becomes impossible to use subclasses of validator
through any API other than Validator.runAll, which is less useful. See for
example my individual validator usage in validator_test.

Powered by Google App Engine