Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(204)

Issue 11195017: Allow package: imports inside isolates (Closed)

Created:
8 years, 2 months ago by justinfagnani
Modified:
8 years, 2 months ago
Reviewers:
siva, Ivan Posva
CC:
reviews_dartlang.org, vm-dev_dartlang.org
Visibility:
Public.

Description

Allow package: imports inside isolates BUG=http://dartbug/5915 Committed: https://code.google.com/p/dart/source/detail?r=13752

Patch Set 1 #

Total comments: 13

Patch Set 2 : Addresses Siva's comments. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+92 lines, -18 lines) Patch
M runtime/bin/dartutils.h View 1 chunk +0 lines, -1 line 0 comments Download
M runtime/bin/dartutils.cc View 1 chunk +4 lines, -9 lines 0 comments Download
M runtime/bin/gen_snapshot.cc View 1 1 chunk +1 line, -1 line 0 comments Download
M runtime/bin/main.cc View 4 chunks +1 line, -4 lines 0 comments Download
M tests/isolate/timer_isolate_test.dart View 1 chunk +1 line, -0 lines 0 comments Download
A tests/standalone/package/package_isolate_test.dart View 1 1 chunk +47 lines, -0 lines 0 comments Download
A tests/standalone/package/sibling_isolate.dart View 1 1 chunk +17 lines, -0 lines 0 comments Download
A tests/standalone/package/test_folder/folder_isolate.dart View 1 1 chunk +17 lines, -0 lines 0 comments Download
A + tests/standalone/package/test_folder/packages/folder_lib.dart View 1 1 chunk +4 lines, -3 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
justinfagnani
8 years, 2 months ago (2012-10-17 01:57:48 UTC) #1
siva
LGTM once comments in the test cases are addressed. https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/package_isolate_test.dart File tests/standalone/package/package_isolate_test.dart (right): https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/package_isolate_test.dart#newcode7 tests/standalone/package/package_isolate_test.dart:7: ...
8 years, 2 months ago (2012-10-17 17:26:23 UTC) #2
justinfagnani
8 years, 2 months ago (2012-10-17 18:11:56 UTC) #3
https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/pack...
File tests/standalone/package/package_isolate_test.dart (right):

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/pack...
tests/standalone/package/package_isolate_test.dart:7: import
'package:shared.dart';
On 2012/10/17 17:26:23, siva wrote:
> I think you should import this with a prefix and use it when
> accessing output to make the test more readable.

Done.

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/pack...
tests/standalone/package/package_isolate_test.dart:13: expect('success', msg);
On 2012/10/17 17:26:23, siva wrote:
> Maybe also have:
> expect('success', <prefix>.output);

It should be a different instance of the output variable, since this code runs
in the main isolate. Adding an expect that it has a different value, like your
next comments, to be sure.

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/pack...
tests/standalone/package/package_isolate_test.dart:20: expectResponse();
On 2012/10/17 17:26:23, siva wrote:
> <prefix>.output = 'junk';

Done.

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/pack...
tests/standalone/package/package_isolate_test.dart:25: test("package in
spawnUri() of sibling file", () {
On 2012/10/17 17:26:23, siva wrote:
> <prefix>.output = 'junk';

Done.

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/sibl...
File tests/standalone/package/sibling_isolate.dart (right):

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/sibl...
tests/standalone/package/sibling_isolate.dart:8: import 'package:shared.dart';
On 2012/10/17 17:26:23, siva wrote:
> I think you should import this with a prefix and then
> use it when accessing output to make the test more readable.

Done.

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/test...
File tests/standalone/package/test_folder/folder_isolate.dart (right):

https://codereview.chromium.org/11195017/diff/1/tests/standalone/package/test...
tests/standalone/package/test_folder/folder_isolate.dart:8: import
'package:folder_lib.dart';
On 2012/10/17 17:26:23, siva wrote:
> I think you should import this with a prefix and use it when accessing count
to
> make the test more readable.

Done.

Powered by Google App Engine
This is Rietveld 408576698