Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(29)

Issue 9699112: Move *keychain_mac* files to crypto/ (Closed)

Created:
8 years, 9 months ago by akalin
Modified:
8 years, 9 months ago
Reviewers:
wtc, Ryan Sleevi
CC:
chromium-reviews
Visibility:
Public.

Description

Move *keychain_mac* files to crypto/ This is in preparation for moving password_manager/encryptor* to crypto/. This also fixes an ODR violation; mock_keychain_mac.cc was being compiled in two targets which are linked together. BUG=118564 TEST= Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=127358

Patch Set 1 #

Total comments: 14

Patch Set 2 : Address comments #

Patch Set 3 : Made another pass #

Total comments: 3
Unified diffs Side-by-side diffs Delta from patch set Stats (+270 lines, -1131 lines) Patch
D chrome/browser/keychain_mac.h View 1 chunk +0 lines, -90 lines 0 comments Download
D chrome/browser/keychain_mac.cc View 1 chunk +0 lines, -109 lines 0 comments Download
D chrome/browser/mock_keychain_mac.h View 1 chunk +0 lines, -207 lines 0 comments Download
D chrome/browser/mock_keychain_mac.cc View 1 chunk +0 lines, -525 lines 0 comments Download
M chrome/browser/password_manager/encryptor_mac.mm View 2 chunks +5 lines, -3 lines 0 comments Download
M chrome/browser/password_manager/encryptor_password_mac.h View 2 chunks +4 lines, -2 lines 0 comments Download
M chrome/browser/password_manager/encryptor_password_mac.mm View 1 chunk +3 lines, -1 line 0 comments Download
M chrome/browser/password_manager/encryptor_password_mac_unittest.cc View 1 chunk +3 lines, -1 line 0 comments Download
M chrome/browser/password_manager/password_store_factory.cc View 2 chunks +4 lines, -4 lines 0 comments Download
M chrome/browser/password_manager/password_store_mac.h View 3 chunks +6 lines, -4 lines 0 comments Download
M chrome/browser/password_manager/password_store_mac.cc View 1 chunk +2 lines, -1 line 0 comments Download
M chrome/browser/password_manager/password_store_mac_internal.h View 1 2 chunks +4 lines, -2 lines 0 comments Download
M chrome/browser/password_manager/password_store_mac_unittest.cc View 1 chunk +2 lines, -1 line 0 comments Download
M chrome/chrome_browser.gypi View 1 2 chunks +0 lines, -4 lines 0 comments Download
M chrome/chrome_tests.gypi View 1 1 chunk +0 lines, -2 lines 0 comments Download
M crypto/crypto.gyp View 1 1 chunk +4 lines, -0 lines 0 comments Download
A + crypto/keychain_mac.h View 1 2 3 chunks +44 lines, -34 lines 3 comments Download
A + crypto/keychain_mac.cc View 1 2 5 chunks +52 lines, -32 lines 0 comments Download
A + crypto/mock_keychain_mac.h View 1 2 6 chunks +61 lines, -42 lines 0 comments Download
A + crypto/mock_keychain_mac.cc View 1 2 20 chunks +76 lines, -67 lines 0 comments Download

Messages

Total messages: 8 (0 generated)
akalin
+ryan for review
8 years, 9 months ago (2012-03-16 08:44:52 UTC) #1
Ryan Sleevi
I like it! Mostly because once or twice I've wanted to use this in net/ ...
8 years, 9 months ago (2012-03-16 20:58:37 UTC) #2
akalin
All comments addressed, committing http://codereview.chromium.org/9699112/diff/1/chrome/browser/password_manager/password_store_mac_internal.h File chrome/browser/password_manager/password_store_mac_internal.h (right): http://codereview.chromium.org/9699112/diff/1/chrome/browser/password_manager/password_store_mac_internal.h#newcode27 chrome/browser/password_manager/password_store_mac_internal.h:27: const MacKeychain* keychain); On 2012/03/16 ...
8 years, 9 months ago (2012-03-17 07:19:44 UTC) #3
commit-bot: I haz the power
CQ is trying da patch. Follow status at https://chromium-status.appspot.com/cq/akalin@chromium.org/9699112/17004
8 years, 9 months ago (2012-03-17 07:19:55 UTC) #4
commit-bot: I haz the power
Change committed as 127358
8 years, 9 months ago (2012-03-17 12:14:51 UTC) #5
wtc
I agree it is a good idea to move these files to crypto so they ...
8 years, 9 months ago (2012-03-19 22:42:28 UTC) #6
akalin
http://codereview.chromium.org/9699112/diff/17004/crypto/keychain_mac.h File crypto/keychain_mac.h (right): http://codereview.chromium.org/9699112/diff/17004/crypto/keychain_mac.h#newcode23 crypto/keychain_mac.h:23: class MacKeychain { On 2012/03/19 22:42:28, wtc wrote: > ...
8 years, 9 months ago (2012-03-19 22:50:03 UTC) #7
wtc
8 years, 9 months ago (2012-03-19 23:03:21 UTC) #8
http://codereview.chromium.org/9699112/diff/17004/crypto/keychain_mac.h
File crypto/keychain_mac.h (right):

http://codereview.chromium.org/9699112/diff/17004/crypto/keychain_mac.h#newco...
crypto/keychain_mac.h:23: class MacKeychain {

On 2012/03/19 22:50:03, akalin wrote:
> Maybe mac_keychain_mac would work better?

mac_keychain_mac looks weird.  I am OK with keychain_mac
(less work) or mac_keychain (requires a GYP change to list
thses files in source! for non-mac platforms).

I guess MockKeychain can be renamed MockMacKeychain and
the files renamed mock_mac_keychain.

Probably not worth the trouble...

Powered by Google App Engine
This is Rietveld 408576698