Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1878)

Unified Diff: base/scoped_native_library.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/safe_strerror_posix.h ('k') | base/scoped_temp_dir.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/scoped_native_library.h
===================================================================
--- base/scoped_native_library.h (revision 95578)
+++ base/scoped_native_library.h (working copy)
@@ -6,7 +6,7 @@
#define BASE_SCOPED_NATIVE_LIBRARY_H_
#pragma once
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/native_library.h"
class FilePath;
@@ -16,7 +16,7 @@
// A class which encapsulates a base::NativeLibrary object available only in a
// scope.
// This class automatically unloads the loaded library in its destructor.
-class BASE_API ScopedNativeLibrary {
+class BASE_EXPORT ScopedNativeLibrary {
public:
// Initializes with a NULL library.
ScopedNativeLibrary();
« no previous file with comments | « base/safe_strerror_posix.h ('k') | base/scoped_temp_dir.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698