Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(99)

Unified Diff: base/base_export.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/base_api.h ('k') | base/callback_internal.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/base_export.h
===================================================================
--- base/base_export.h (revision 95116)
+++ base/base_export.h (working copy)
@@ -2,25 +2,25 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-#ifndef BASE_BASE_API_H_
-#define BASE_BASE_API_H_
+#ifndef BASE_BASE_EXPORT_H_
+#define BASE_BASE_EXPORT_H_
#pragma once
#if defined(COMPONENT_BUILD)
#if defined(WIN32)
#if defined(BASE_IMPLEMENTATION)
-#define BASE_API __declspec(dllexport)
+#define BASE_EXPORT __declspec(dllexport)
#else
-#define BASE_API __declspec(dllimport)
+#define BASE_EXPORT __declspec(dllimport)
#endif // defined(BASE_IMPLEMENTATION)
#else // defined(WIN32)
-#define BASE_API __attribute__((visibility("default")))
+#define BASE_EXPORT __attribute__((visibility("default")))
#endif
#else // defined(COMPONENT_BUILD)
-#define BASE_API
+#define BASE_EXPORT
#endif
-#endif // BASE_BASE_API_H_
+#endif // BASE_BASE_EXPORT_H_
« no previous file with comments | « base/base_api.h ('k') | base/callback_internal.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698