Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(175)

Issue 4925001: Packetizer/Depacketizer for RTP. (Closed)

Created:
10 years, 1 month ago by Sergey Ulanov
Modified:
9 years, 7 months ago
CC:
chromium-reviews, Alpha Left Google, Sergey Ulanov, dmac, awong, garykac, Paweł Hajdan Jr.
Visibility:
Public.

Description

Packetizer/Depacketizer for RTP. BUG=None TEST=None Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=66213

Patch Set 1 : - #

Patch Set 2 : - #

Patch Set 3 : Fixed some bugs #

Patch Set 4 : - #

Total comments: 28

Patch Set 5 : addressed Alpha's comments #

Total comments: 6

Patch Set 6 : - #

Patch Set 7 : - #

Unified diffs Side-by-side diffs Delta from patch set Stats (+437 lines, -70 lines) Patch
M remoting/protocol/rtp_reader.h View 1 2 3 4 2 chunks +6 lines, -1 line 0 comments Download
M remoting/protocol/rtp_reader.cc View 1 2 3 1 chunk +14 lines, -4 lines 0 comments Download
M remoting/protocol/rtp_utils.h View 1 2 3 4 1 chunk +30 lines, -5 lines 0 comments Download
M remoting/protocol/rtp_utils.cc View 1 2 3 4 5 6 3 chunks +170 lines, -17 lines 0 comments Download
M remoting/protocol/rtp_video_reader.h View 1 2 3 4 1 chunk +12 lines, -1 line 0 comments Download
M remoting/protocol/rtp_video_reader.cc View 1 2 3 4 2 chunks +121 lines, -8 lines 0 comments Download
M remoting/protocol/rtp_video_writer.cc View 1 2 3 2 chunks +54 lines, -2 lines 0 comments Download
M remoting/protocol/rtp_writer.h View 1 2 3 4 2 chunks +5 lines, -2 lines 0 comments Download
M remoting/protocol/rtp_writer.cc View 1 2 3 3 chunks +25 lines, -30 lines 0 comments Download

Messages

Total messages: 8 (0 generated)
Sergey Ulanov
10 years, 1 month ago (2010-11-12 23:13:08 UTC) #1
Alpha Left Google
http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_reader.h File remoting/protocol/rtp_reader.h (left): http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_reader.h#oldcode38 remoting/protocol/rtp_reader.h:38: typedef Callback1<const RtpPacket&>::Type OnMessageCallback; why this is changed to ...
10 years, 1 month ago (2010-11-15 23:46:35 UTC) #2
Sergey Ulanov
http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_reader.h File remoting/protocol/rtp_reader.h (left): http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_reader.h#oldcode38 remoting/protocol/rtp_reader.h:38: typedef Callback1<const RtpPacket&>::Type OnMessageCallback; On 2010/11/15 23:46:35, Alpha wrote: ...
10 years, 1 month ago (2010-11-16 00:22:55 UTC) #3
Alpha Left Google
http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_utils.cc File remoting/protocol/rtp_utils.cc (right): http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_utils.cc#newcode172 remoting/protocol/rtp_utils.cc:172: buffer[0] = On 2010/11/16 00:22:55, sergeyu wrote: > On ...
10 years, 1 month ago (2010-11-16 00:47:07 UTC) #4
Sergey Ulanov
I've added comments about order of bits on the diagrams. On Mon, Nov 15, 2010 ...
10 years, 1 month ago (2010-11-16 01:06:10 UTC) #5
Alpha Left Google
LGTM.
10 years, 1 month ago (2010-11-16 01:06:42 UTC) #6
awong
Seems like Alpha's got this review. I'll just send the comments that I had. LGTM ...
10 years, 1 month ago (2010-11-16 01:08:40 UTC) #7
Sergey Ulanov
10 years, 1 month ago (2010-11-16 01:52:25 UTC) #8
http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_utils.cc
File remoting/protocol/rtp_utils.cc (right):

http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_utils...
remoting/protocol/rtp_utils.cc:38: //
+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
On 2010/11/16 01:08:40, awong wrote:
> nice diagram.:)
I didn't draw it myself, it's from RTP spec :)

http://codereview.chromium.org/4925001/diff/10001/remoting/protocol/rtp_utils...
remoting/protocol/rtp_utils.cc:173: ((uint8)(descriptor.picture_id !=
kuint32max) << 4) +
On 2010/11/16 01:08:40, awong wrote:
> Since we're playing in bits, I'm personally happier seeing | over +.  Any
reason
> to choose +?
Agree that | is better here. Fixed here and in PackRtpHeader.

http://codereview.chromium.org/4925001/diff/17001/remoting/protocol/rtp_utils...
remoting/protocol/rtp_utils.cc:46: return kRtpBaseHeaderSize + header.sources *
4;
On 2010/11/16 01:08:40, awong wrote:
> magic number....why *4?
Size of each CSRC in the header. Added kBytesPerCSRC.

http://codereview.chromium.org/4925001/diff/17001/remoting/protocol/rtp_utils...
remoting/protocol/rtp_utils.cc:194: 
On 2010/11/16 01:08:40, awong wrote:
> I personally find 0x80 to be easier to read -- espcially since it's symmetric
> with the mask below -- but whatever works.

Done.

http://codereview.chromium.org/4925001/diff/17001/remoting/protocol/rtp_utils...
remoting/protocol/rtp_utils.cc:210: while (extension) {
On 2010/11/16 01:08:40, awong wrote:
> Can we invert this conditional, and early return on the degenerate case of not
> having a picture_id?
> 
> Then the rest of the code can be moved out one level...

Done.

Powered by Google App Engine
This is Rietveld 408576698