Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(108)

Issue 100337: Changed some int casts to intptr_t. (Closed)

Created:
11 years, 7 months ago by Lasse Reichstein
Modified:
9 years, 6 months ago
CC:
v8-dev
Visibility:
Public.

Description

Changed some int casts to intptr_t. Removed a drop in an ocean of compile errors in x64 mode.

Patch Set 1 #

Total comments: 2
Unified diffs Side-by-side diffs Delta from patch set Stats (+19 lines, -17 lines) Patch
M src/checks.h View 1 chunk +1 line, -1 line 0 comments Download
M src/objects.h View 2 chunks +5 lines, -4 lines 2 comments Download
M src/objects-inl.h View 3 chunks +4 lines, -3 lines 0 comments Download
M src/spaces.h View 3 chunks +9 lines, -9 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
Lasse Reichstein
Comments?
11 years, 7 months ago (2009-05-04 12:44:57 UTC) #1
Lasse Reichstein
Comments?
11 years, 7 months ago (2009-05-04 12:45:00 UTC) #2
Dean McNamee
11 years, 7 months ago (2009-05-04 13:04:14 UTC) #3
http://codereview.chromium.org/100337/diff/1/4
File src/objects.h (right):

http://codereview.chromium.org/100337/diff/1/4#newcode801
Line 801: static const int kMaxValue = (1 << (kSmiPrecission - (kSmiTagSize))) -
1;
I would call this kSmiNumBits, precision (spelling) doesn't really make it clear
that it's the number of bits.

http://codereview.chromium.org/100337/diff/1/4#newcode2329
Line 2329: reinterpret_cast<uintptr_t>(address()),
Do we really need this, both should be returning pointers, instruction_start
returns a byte*, and address returns an Address (which is also a byte*).  Is
there something about subtracting pointers I'm missing?

Powered by Google App Engine
This is Rietveld 408576698