Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(155)

Unified Diff: Source/bindings/core/v8/V8BindingMacros.h

Issue 946973005: IDL: Drop value conversion (V8 -> C++) macros from generated code (Closed) Base URL: https://chromium.googlesource.com/chromium/blink.git@master
Patch Set: Created 5 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: Source/bindings/core/v8/V8BindingMacros.h
diff --git a/Source/bindings/core/v8/V8BindingMacros.h b/Source/bindings/core/v8/V8BindingMacros.h
index 320cff6709bc0214451db6363bb4e03dfc294f1f..950977b785a93ba6b6428663387ac9b34e89767b 100644
--- a/Source/bindings/core/v8/V8BindingMacros.h
+++ b/Source/bindings/core/v8/V8BindingMacros.h
@@ -33,6 +33,14 @@
namespace blink {
+#define TONATIVE_CONVERT(expression, bailout) \
+ if (!(expression)) \
+ bailout; \
+
+#define TONATIVE_DECLARE(type, var, expression, bailout) \
yhirano 2015/02/24 03:51:24 [optional] This is not a strong opinion, but I don
Jens Widell 2015/02/24 07:31:43 Essentially, I don't see a strong benefit to eithe
+ type var; \
+ TONATIVE_CONVERT(expression, bailout)
+
// Naming scheme:
// TO*_RETURNTYPE[_ARGTYPE]...
// ...using _DEFAULT instead of _ANY..._ANY when returing a default value.

Powered by Google App Engine
This is Rietveld 408576698