Chromium Code Reviews
Help | Chromium Project | Gerrit Changes | Sign in
(72)

Issue 877433003: metatest: Update min version of unittest to support development (Closed)

Created:
5 years, 5 months ago by kevmoo
Modified:
5 years, 5 months ago
Reviewers:
nweiz
CC:
reviews_dartlang.org
Base URL:
https://github.com/dart-lang/metatest.git@master
Target Ref:
refs/heads/master
Visibility:
Public.

Description

Update min version of unittest to support development Committed: https://github.com/dart-lang/metatest/commit/cc928ccf56f7dc40e4497ed35a95d96694ab7cc6

Patch Set 1 #

Total comments: 2
Unified diffs Side-by-side diffs Delta from patch set Stats (+6 lines, -4 lines) Patch
M CHANGELOG.md View 1 chunk +4 lines, -0 lines 0 comments Download
M lib/metatest.dart View 2 chunks +0 lines, -2 lines 0 comments Download
M pubspec.yaml View 1 chunk +2 lines, -2 lines 2 comments Download

Messages

Total messages: 4 (1 generated)
kevmoo
TBR
5 years, 5 months ago (2015-01-27 01:11:28 UTC) #2
kevmoo
Committed patchset #1 (id:1) manually as cc928ccf56f7dc40e4497ed35a95d96694ab7cc6 (presubmit successful).
5 years, 5 months ago (2015-01-27 01:11:40 UTC) #3
nweiz
5 years, 5 months ago (2015-01-27 01:27:01 UTC) #4
Message was sent while issue was closed.
I really wish you hadn't released this package. I may have to manually delete it
to prevent versioning issues in the future.

https://codereview.chromium.org/877433003/diff/1/pubspec.yaml
File pubspec.yaml (right):

https://codereview.chromium.org/877433003/diff/1/pubspec.yaml#newcode2
pubspec.yaml:2: version: 0.1.1
Why is this not a development version? If this CL exists to support development
versions of unittest, it should itself be a development version.

https://codereview.chromium.org/877433003/diff/1/pubspec.yaml#newcode9
pubspec.yaml:9: unittest: '>=0.11.0 <=0.12.0'
A "<=" constraint should never be used. What you're expressing here is that this
package will be compatible with unittest 0.12.0, which you don't know since that
doesn't exist yet, but it *won't* be compatible with 0.12.0+1 or any other
backwards-compatible unittest version, which just doesn't make sense.

Powered by Google App Engine
This is Rietveld 408576698