Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(679)

Unified Diff: runtime/vm/code_generator.cc

Issue 861393004: Rename DeoptimizeAll to DeoptimizeFunctionsOnStack. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 5 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « runtime/vm/code_generator.h ('k') | runtime/vm/debugger.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: runtime/vm/code_generator.cc
diff --git a/runtime/vm/code_generator.cc b/runtime/vm/code_generator.cc
index b520549b252d26f359b8ffb50923e3df6def0383..0cd7a05af92a9bd522c00029c83c239a5e24852a 100644
--- a/runtime/vm/code_generator.cc
+++ b/runtime/vm/code_generator.cc
@@ -1169,7 +1169,7 @@ DEFINE_RUNTIME_ENTRY(StackOverflow, 0) {
}
if (do_deopt) {
// TODO(turnidge): Consider using DeoptimizeAt instead.
- DeoptimizeAll();
+ DeoptimizeFunctionsOnStack();
}
if (do_stacktrace) {
String& var_name = String::Handle();
@@ -1468,7 +1468,7 @@ void DeoptimizeAt(const Code& optimized_code, uword pc) {
// Currently checks only that all optimized frames have kDeoptIndex
// and unoptimized code has the kDeoptAfter.
-void DeoptimizeAll() {
+void DeoptimizeFunctionsOnStack() {
DartFrameIterator iterator;
StackFrame* frame = iterator.NextFrame();
Code& optimized_code = Code::Handle();
« no previous file with comments | « runtime/vm/code_generator.h ('k') | runtime/vm/debugger.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698