Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(261)

Unified Diff: Source/modules/push_messaging/PushSubscription.idl

Issue 841333002: Push API: rename registration to subscription. (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: similarity=30 Created 5 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: Source/modules/push_messaging/PushSubscription.idl
diff --git a/Source/modules/push_messaging/PushRegistration.idl b/Source/modules/push_messaging/PushSubscription.idl
similarity index 44%
rename from Source/modules/push_messaging/PushRegistration.idl
rename to Source/modules/push_messaging/PushSubscription.idl
index 243215d9fc20fb200d414d64097ca52d7a21f3df..81451a4bdfb68ca59de6cde339dda5b2e0add7b7 100644
--- a/Source/modules/push_messaging/PushRegistration.idl
+++ b/Source/modules/push_messaging/PushSubscription.idl
@@ -1,14 +1,14 @@
-// Copyright 2014 The Chromium Authors. All rights reserved.
+// Copyright 2015 The Chromium Authors. All rights reserved.
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-// http://www.w3.org/TR/push-api/#pushregistration-interface
+// http://w3c.github.io/push-api/#pushsubscription-interface
[
GarbageCollected,
RuntimeEnabled=PushMessaging,
-] interface PushRegistration {
+] interface PushSubscription {
readonly attribute DOMString endpoint;
- readonly attribute DOMString registrationId;
- [CallWith=ScriptState] Promise<boolean> unregister();
+ readonly attribute DOMString subscriptionId;
+ [CallWith=ScriptState] Promise<boolean> unsubscribe();
};

Powered by Google App Engine
This is Rietveld 408576698