Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(492)

Unified Diff: remoting/client/plugin/touch_input_scaler.h

Issue 799233004: Add touch events to the protocol, the stub layer, and to the client plugin. (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Renamed TouchInputFilter to TouchInputScaler and moved to client/plugin Created 5 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: remoting/client/plugin/touch_input_scaler.h
diff --git a/remoting/client/plugin/touch_input_scaler.h b/remoting/client/plugin/touch_input_scaler.h
new file mode 100644
index 0000000000000000000000000000000000000000..7e126f0eacfbcac87259a468e2cf287a311ee07a
--- /dev/null
+++ b/remoting/client/plugin/touch_input_scaler.h
@@ -0,0 +1,46 @@
+// Copyright 2015 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
+
+#ifndef REMOTING_CLIENT_PLUGIN_TOUCH_INPUT_SCALER_H_
+#define REMOTING_CLIENT_PLUGIN_TOUCH_INPUT_SCALER_H_
+
+#include "remoting/protocol/input_filter.h"
+#include "third_party/webrtc/modules/desktop_capture/desktop_geometry.h"
+
+namespace remoting {
+
+namespace protocol {
+class TouchEvent;
+} // namespace protocol
+
+// Scales the coordinates to host x,y value. The
Sergey Ulanov 2015/01/29 18:00:46 finish the comment
Rintaro Kuroiwa 2015/01/30 17:57:02 Done.
+// TODO(rkuroiwa): Consider renaming this to TouchInputScaler.
+class TouchInputScaler : public protocol::InputFilter {
+ public:
+ TouchInputScaler() = default;
+ explicit TouchInputScaler(InputStub* input_stub);
+ ~TouchInputScaler() override;
+
+ void set_input_size(const webrtc::DesktopSize& size) {
+ input_size_.set(size.width() - 1, size.height() - 1);
Sergey Ulanov 2015/01/29 18:00:46 why do you need -1 here?
Rintaro Kuroiwa 2015/01/30 17:57:02 Added a comment.
+ }
+
+ void set_output_size(const webrtc::DesktopSize& size) {
+ output_size_.set(size.width() - 1, size.height() - 1);
+ }
+
+ // protocol::InputStub interface.
+ void InjectTouchEvent(const protocol::TouchEvent& event) override;
+
+ private:
+ // Sizes for scaling the coordinates.
+ webrtc::DesktopSize input_size_;
+ webrtc::DesktopSize output_size_;
+
+ DISALLOW_COPY_AND_ASSIGN(TouchInputScaler);
+};
+
+} // namespace remoting
+
+#endif // REMOTING_CLIENT_PLUGIN_TOUCH_INPUT_SCALER_H_

Powered by Google App Engine
This is Rietveld 408576698